Message
"Sorry, we're having some trouble. Please try again."
Cause
Purchase PIN error (Can't determine if Purchase PIN is set, or cannot validate Purchase PIN) (500-105). Parental Control Service: Any other unhandled error, or communication issue.
Cause code
This transaction is not currently available.
Solution code
Reset your Purchase PIN at secure.xfinity.com/profile/settings/parental-controls and try again. If the issue persists, please contact us.
Additional information
Visit our Online Support Center to find common solutions.

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